Thread Rating:
  • 3 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Movie Subtitles Now Supported
(04-02-2015, 08:16 AM)masoko Wrote: I can see the subtitles option on youtube movies but not on YTS torrents.
Does YTS Movies = YTS Torrents or YTS Movies is something different?



YTS Movies = YTS Torrrents.

Check you have the latest version of YTS Torrents by doing:
cd blissflixx/plugins/bfch_yts_torrents

Then running:

git pull

Now restart blissflixx server and refresh your browser
~/blissflixx/plugins/bfch_yts_torrents $ git pull
Already up-to-date.

Updated and restarted BlissFlixx using the web interface.
Refreshed the browser with crl+f5 tried different browsers - no subs in YTS but there are subs in youtube movies and kickass torrents.
Very strange...

Lets double check you have the latest yts plugin:

cd blissflixx/plugins/bfch_yts_torrents

Now open in your favourite editor:


Can you confirm that the lines 68 and 69 contain the following code:

   subs = movie_title_year(title)
   results.add(TorrentPlayItem(title, img, url, subtitle, synopsis, subs))
not sure if they are lines 68 and 69 but they are very close to the EOF
here are the last N lines containing the subs string:

subs = movie_title_year(title)
results.add(TorrentPlayItem(title, img, url, subtitle, synopsis, subs))
return results

def _smallest_size(torrlist):
size = torrlist[0]['size_bytes']
torrent = torrlist[0]
for t in torrlist:
if t['size_bytes'] < size:
size = t['size_bytes']
torrent = t
return torrent

---------- when I saw the subs missing I have reinstalled this plugin by deleting its folder and running the install command
Yes it looks like you definitely have the latest version. Let me have a think about what to try next...
OK try this. Paste the following url in your browser (replace the with the ip address of your Raspberry PI):


Can you show me the output? (just the first 10 lines or so)
I have found the problem.
When installing the server I have installed YTS plugin in the root of blissflixx not in plugins and it was not recognizes, so I have installed again in plugins and forgot to delete the wrong installation.
Now when I deleted the plugin from the root of Blissflixx and restarted the server everything works file.

Thanks for your support.
The subs look to work fine - I'll be able to confirm once I get home as I can't see the hdmi output from work - I can just ssh and watch the web interface which seem to be working fine.

Thank you for the fast release of the subs functionality! Keep the good work.
Please help I have updated my pi and blissflixx subs stoped working.
I have run apt-get update and then apt-get upgrade and now when I try to play with subs the page content disapears - I can see the header navigation and the dark blue body of the page but that is all.

To fix it I have tried reinstalling blissflixx and its plugins but the issue remains.

Here is the output you requested yesterday

[{"subtitle": "Size: 813.65 MB, Seeds: 981, Peers: 791", "subs": {"lang": "eng", "year": 1984, "title": "1984"}, "img": "", "title": "1984 (1984)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "1984 (1984)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 7.2</a>"}, {"subtitle": "Size: 759.51 MB, Seeds: 767, Peers: 571", "subs": {"lang": "eng", "year": 2012, "title": "Found"}, "img": "", "title": "Found (2012)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "Found (2012)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 6.1</a>"}, {"subtitle": "Size: 877.12 MB, Seeds: 907, Peers: 919", "subs": {"lang": "eng", "year": 2002, "title": "Amen"}, "img": "", "title": "Amen. (2002)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "Amen. (2002)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 7.3</a>"}, {"subtitle": "Size: 754.07 MB, Seeds: 6544, Peers: 4238", "subs": {"lang": "eng", "year": 2014, "title": "Wyrmwood: Road of the Dead"}, "img": "", "title": "Wyrmwood: Road of the Dead (2014)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "Wyrmwood: Road of the Dead (2014)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 6.3</a>"}, {"subtitle": "Size: 809.11 MB, Seeds: 424, Peers: 171", "subs": {"lang": "eng", "year": 1971, "title": "The Magnificent Seven Deadly Sins"}, "img": "", "title": "The Magnificent Seven Deadly Sins (1971)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "The Magnificent Seven Deadly Sins (1971)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 5.5</a>"}, {"subtitle": "Size: 698.85 MB, Seeds: 1616, Peers: 763", "subs": {"lang": "eng", "year": 2014, "title": "From the Dark"}, "img": "", "title": "From the Dark (2014)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "From the Dark (2014)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 5.6</a>"}, {"subtitle": "Size: 814.77 MB, Seeds: 25833, Peers: 13590", "subs": {"lang": "eng", "year": 2014, "title": "Taken 3"}, "img": "", "title": "Taken 3 (2014)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "Taken 3 (2014)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 6.1</a>"}, {"subtitle": "Size: 874.29 MB, Seeds: 250, Peers: 168", "subs": {"lang": "eng", "year": 1965, "title": "Darling"}, "img": "", "title": "Darling (1965)", "url": "", "actions": [{"type": "playwithsubs", "label": "Play With Subtitles"}, {"type": "addplaylist", "label": "Add To Playlist"}, {"link": "", "title": "Darling (1965)", "type": "torrfiles", "label": "View Files..."}], "synopsis": "<a target='_blank' href=''>IMDB Rating: 7.2</a>"}, {"subtitle": "Size: 809.23 MB, Seeds: 6097, Peers: 3056", "subs": {"lang": "eng", "year": 2014, "title": "Cake"}, "img":

Thank you,

I have just noticed that the only palce where subs work is the kickass TV serials, maybe when you add this it broke the rest of the subs - atleast for me.
>> maybe when you add this it broke the rest of the subs - atleast for me.

Yes you are right - I broke other subs  Sad

Anyway it is now fixed. Just restart & update and then refresh your browser by pressing ctrl key + F5

Sorry about that.
I can see the subs screen now but I can't get past it - clicking paly just reloads the page and shows the subs selection screen again - only option is to hit cancel and go back to the catalog.
Tried resatrting the server - f5 /crtl+f5 different browser.

Forum Jump:

Users browsing this thread: 1 Guest(s)