Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Plugins for YTS, Kickass, EZTV, Pirate Bay
#11
What version of Raspberry Pi are you running?
Reply
#12
Also make sure you are running the lastest version:

1/ Start blissflixx server.
2/ Goto the settings page (last icon on top menu bar)
3/ Select "RESTART & UPDATE"
4/ Wait to server has restarted
5/ Try playing torrent again
Reply
#13
(03-21-2015, 02:48 PM)MrBliss Wrote: Also make sure you are running the lastest version:

1/ Start blissflixx server.
2/ Goto the settings page (last icon on top menu bar)
3/ Select "RESTART & UPDATE"
4/ Wait to server has restarted
5/ Try playing torrent again

I am on rpi 2.
I have already done the 5 steps described above - will try again.
I believe I have the latest version of your soft as I installed it 2 days ago - I was never able to run torrent - the problem is not in the plugin but my BlissFlixx installation.

Is there a log I can check for more detailed errors ?

Thank you,
Masoko
Reply
#14
Another thing to try: Run the following command:

Code:
/usr/local/bin/peerflix https://yts.to/torrent/download/6419775CCBF3833859449C940C2E2357DD7F2613.torrent

This will start downloading the torrent. Once you can see the download has started run the following command in another window session:

Code:
omxplayer -b --timeout 100 -I --no-keys  http://127.0.0.1:8888

After about 1 minute the film should start playing. This is almost exactly how blissflixx executes the commands.



Quote:Is there a log I can check for more detailed errors ?

The only log is the one you posted at the beginning. This shows that the first command above is started to download the torrent (which works fine) then the next command above is executed to start omxplayer. At this point it fails since omxplayer just exits without playing the video. Maybe when you do the above commands manually we will see the error appearing
Reply
#15
Ok I just pushed a small change to the server to give us a clue about why omxplayer fails:

1/ Restart the server as I described in post #12 to get the latest change
2/ Start the server: ./blissflixx.sh
3/ Try and play the torrent
4/ Post the debug output

Thanks
Reply
#16
I found the problem.
I have rpimonitor installed and it is using port 8888 if I stop it torrents play fine.
http://rpi-experiences.blogspot.com/p/rpi-monitor.html
Is there a chance you can change this port to something else as rpimonitor is a really good app and I don't want to stop using it.

Thank you,
Reply
#17
Great that you found the problem  Big Grin

I will change the port from 8888 to something else tomorrow. Let you know when it's done.

Happy movie watching  !
Reply
#18
OK I changed the port to 9696

To update goto the settings page and select "RESTART & UPDATE
Reply
#19
I have updated and restarted as suggested - even restarted my rpi but I still can't get rpimonitor and blissflixx to run together.
How can I confirm that the port is changed ? I don't believe that rpimonitor needs 9696 .

Thank you
Reply
#20
You can confirm the port changes by first starting to play a torrent. When the torrent video is showing run the following command on the RPi

Code:
ps -ef | grep peerflix

This will show the port peerflix is serving on. You should be seeing:
Code:
/bin/sh -c omxplayer -b --timeout 100 -I --no-keys 'http://127.0.0.1:9696'


If you still have problems maybe I will install rpimonitor to see if I can reproduce your issues.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)