Welcome, Guest
You have to register before you can post on our site.

Username
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 1,714
» Latest member: hotelmashhad1
» Forum threads: 51
» Forum posts: 258

Full Statistics

Online Users
There are currently 35 online users.
» 0 Member(s) | 35 Guest(s)

Latest Threads
BBC iPlayer category & se...
Forum: General
Last Post: SteveDee
08-19-2017, 04:49 PM
» Replies: 4
» Views: 1,967
Playlist continuous auto ...
Forum: Feature Requests
Last Post: MrBliss
10-19-2016, 03:01 PM
» Replies: 5
» Views: 4,041
Local directory as a chan...
Forum: Feature Requests
Last Post: MrBliss
10-07-2016, 12:51 PM
» Replies: 2
» Views: 1,253
Loca Media File Plugin
Forum: Plugins
Last Post: MrBliss
10-07-2016, 12:49 PM
» Replies: 0
» Views: 1,415
Subtitle localization for...
Forum: General
Last Post: MrBliss
10-05-2016, 04:45 PM
» Replies: 4
» Views: 6,837
[Tutorial] How to make th...
Forum: Tutorials
Last Post: MrBliss
09-26-2016, 07:35 AM
» Replies: 6
» Views: 7,607
Blissflixx cannot start
Forum: General
Last Post: SteveDee
09-20-2016, 06:06 PM
» Replies: 2
» Views: 3,399
Torrent timeout
Forum: General
Last Post: MrBliss
09-05-2016, 06:32 PM
» Replies: 1
» Views: 2,656
Torrent Download Progress
Forum: General
Last Post: MrBliss
08-18-2016, 03:56 AM
» Replies: 1
» Views: 2,379
subtitle not available fr...
Forum: General
Last Post: echbeno
08-12-2016, 08:34 PM
» Replies: 2
» Views: 2,473

 
  YTS at 1080p
Posted by: tomcontr - 04-19-2016, 03:50 AM - Forum: Plugins - Replies (4)

Hi guys,
Thanks for creating this awesome tool. (BlissFlixx). I have installed YTS plugins at it works perfectly. The only thing that I didnt like is that it only shows movies at 720p.
So I created a simple PHP script that help me fix this problem on my end. At least until the creator of this great plugin can fix it more permanently.

If anyone is interested what you have to do is put this code into a PHP file on any server that BlissFlixx can have access. It can be an Apache Server hosted on your raspberry pi, it doesnt matter really.
What it does is remove all 720p movies, so you can now select the 1080p ones. Dont use this script if your seed is not good enough.

Code:
<?php
$a =  file_get_contents("https://yts.ag/api/v2/list_movies.json?query_term=".$_GET['query_term']."&limit=".$_GET['limit']);
$b = explode('torrents":[',$a);
$i = 0;
$final = $b[0];
while($i < count($b))
        {
        $c = explode(']',$b[$i+1]);
                if (!preg_match("/},/",$c[0]))
                        {
                        }
                else
                        {
                        $d = explode("},",$c[0]);
                        $j=0;
                        while($j <count($d))
                                {
                                if (preg_match("/720p/",$d[$j]))
                                        {
                                        $a = str_replace($d[$j]."},","",$a);
                                        }
                                $j++;
                              }

                        }
        $i++;
        }
echo $a;
?>

Then go into yout BlissFlixx Intalation directory and edit the YTS plug in (File: __init__.py)
and change this line:
_SEARCH_URL = 'https://yts.ag/api/v2/list_movies.json'

for

_SEARCH_URL = 'http://yourdomain.com/yourphpscript.php'

That's it. I hope this is useful for you as it was for me.

Best Regards,

By the way.
I tried to watch the movie "Point Brake 2015" (at 1080p on YTS Plugin) and the Subtitles were wrong. It were probably from another movie. Is there any way to fix that?

Regards,

Print this item

  Not full screen and no audio
Posted by: rmeskill - 04-03-2016, 11:14 PM - Forum: General - Replies (4)

Hello-I've managed to get blissflixx setup, but I have two issues:

1) I can't ever get true full-screen. I've tried both CLI and GUI boot options for Raspberry Pi, but I always end up with the video only taking up 95% of the screen, with lines of the screen behind above and below. It's not world-ending, just annoying-any thoughts on how to get rid of that?
2) I don't have audio. I've forced audio out the HDMI port via raspi-config, but no dice-don't get audio for videos. This is world-ending, at least for using Blissflixx...


To be fair, when I boot into a command prompt, the background screen fades away soon enough, so it's only annoying for the first few minutes, but still no audio...

Print this item

  Load subtitles by url
Posted by: 0bscur3 - 03-29-2016, 03:42 AM - Forum: Feature Requests - Replies (1)

First, sorry for my bad english. Second, MrBliss, BlissFlixx is AMAZING. I already tried multiple solutions but there is not any that comes close to the power of BlissFlixx. I want to create a little windows app that create an entry on explorer context menu, "Play on BlissFlixx". The app will create a http server and pass the video url like this:

Code:
http://rasberry_pi_ip/api/playr?fn=play&data={"url":"https://my_machine_ip/myvideo.mp4","title":"some title"}

Now, I have some videos that already have subtitles on the same folder. Is it possible to pass the srt file just like I can pass the video file? I tried to do like this:

Code:
http://rasberry_pi_ip/api/playr?fn=play&data={"url":"http://my_machine_ip/myvideo.mp4","subs":"http://my_machine_ip/myvideo.srt","title":"some title"}

but BlissFlixx got stuck on "Fetching Subtitles" (it probably was not expecting an url). Is this scenario possible already?

Again, thank you for your amazing work!

Print this item

  Wifi Configurator
Posted by: SteveDee - 03-02-2016, 04:26 PM - Forum: General - Replies (1)

I've modified my BlissFlixx system to allow simple wifi configuration and to display the Pi IP address on the initial boot screen.

If this is of interest, take a look at my notes here: http://captainbodgit.blogspot.co.uk/2016/03/blissflixx-wifi-config-user-information.html

Print this item

  Video issue with TED Talks
Posted by: SteveDee - 02-28-2016, 08:53 PM - Forum: General - Replies (2)

We have been using BlissFlixx for a couple on months, mostly on BBC iPlayer, ITV Player and TED Talks. It all runs well, except that we get a curious problem with some TED Talks.

When we run a "talk" the TED intro screen is OK, but as the actual "talk" part of the video starts, we sometimes get apparent video corruption. Typically we may see a grey screen with a ghostly moving outline of the speaker. But the screen may sometimes be a colour (say pink) with a few flickering coloured pixels.

This state rarely lasts more than 10 or 20 seconds, but on Al Gores latest offering (http://www.ted.com/talks/al_gore_the_case_for_optimism_on_climate_change#t-15472) it goes on for about 30 seconds, then recovers and remains OK. If I play this video on one of our laptops it is absolutely fine.

We have never seen this problem on any other channel.

I'd be grateful if someone would try the link above on BlissFlixx to see if they have the same issue, or let me know if it's a known problem.

Print this item

  Sometimes fails to run from start
Posted by: SteveDee - 01-08-2016, 01:37 PM - Forum: General - Replies (2)

I'm a new convert to BlissFlixx, its great!

But I sometimes get a problem when I boot my system (maybe 1 in 5 times) where the Pi reports the following:-

Code:
{date/time} BLISSFLIXX Starting...
Traceback (most recent call last):
File "/home/pi/blissflixx/blissflixx.py", line 47 in <module>
import api, pwd, grp
...and this message continues in a similar way referencing lines 1, 129, 71 & so on.

I just cold-boot again and its usually fine.

I've configured my Pi as per this post on my blog: http://captainbodgit.blogspot.co.uk/2016/01/blissflixx-on-raspberrypi.html

Any ideas or suggestions would be appreciated.

Looks like adding a delay to blissflixx.py may be a work-around...

Code:
#!/usr/bin/python
from os import path
import sys, os
LIB_PATH = path.join(path.abspath(path.dirname(__file__)), "lib")
sys.path.append(LIB_PATH)
import locations, gitutils, cherrypy
import time
print ".............enforce a 10 second delay....."
time.sleep(10)

# Do not allow running as root

I'll live with it/tune it for a while and see what happens.

Print this item

  YTS Plugin Working Again
Posted by: Brian - 11-13-2015, 01:22 PM - Forum: Plugins - Replies (2)

The YTS plugin is now working again  Big Grin Please update to the latest release.

Brian

Print this item

  EZTV Error 500 When loading Popular
Posted by: mr.blissLover - 10-30-2015, 11:24 PM - Forum: General - Replies (3)

Error message when I load the Popular channel of EZTV. Anyone else having similar problems/ know the solution to fix this problem?

Here's the error output:

Code:
Traceback (most recent call last):
 File "./blissflixx.py", line 95, in default
   ret = call(**datadict)
 File "/home/pi/blissflixx/lib/api/channels.py", line 176, in feed
   return installed.getChannel(chid).getFeed(idx)
 File "/home/pi/blissflixx/lib/api/channels.py", line 61, in getFeed
   return self.getPlayItems(self.module.feed(idx))
 File "/home/pi/blissflixx/plugins/bfch_eztv/__init__.py", line 28, in feed
   data = get_json(_FEEDLIST[idx]['url'], proxy=True)
 File "/home/pi/blissflixx/lib/chanutils/chanutils.py", line 75, in get_json
   r = get(url, params=params, **kwargs)
 File "/home/pi/blissflixx/lib/chanutils/chanutils.py", line 42, in get
   raise Exception("Request : '" + url + "' returned: " + str(r.status_code))
Exception: Request : 'http://blissflixx-proxy1.appspot.com' returned: 500

Print this item

  torrent stream prob.
Posted by: jimbob321 - 09-30-2015, 02:24 PM - Forum: General - Replies (4)

ok i tried to install peerflix as directed from rasp forum
really confused

pi@raspberrypi ~ $ npm install -g peerflix
/usr/local/bin/node: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/local/bin/node)
/usr/local/bin/node: /lib/arm-linux-gnueabihf/libc.so.6: version `GLIBC_2.16' not found (required by /usr/local/bin/node)

ok i am going to download raspbian jessie and try again i had wheezy

thanks
jimmy

Print this item

  Recall Audio Settings
Posted by: mr.blissLover - 09-28-2015, 09:14 AM - Forum: Feature Requests - Replies (3)

It'd be useful if a file or variable could store the volume setting the user has adjusted it to and apply the same volume level the next time omxplayer is launched.

example:
Bob is playing a playlist of reddit videos and notices they are all playing through his speakers dangerously loud, Bob thus adjust the volume decibels using the Blissflixx server to level -12.0 db for the current video playing, the video plays at the appropriate volume of -12db that Bob has specified. Now the video is over and our good friend Bob selects the next video in his playlist, and his speakers get blown the fuck out because instead of playing the second video at -12db like Bob specified in the prior video, this second video is played at the default 0 db and so blow Bob's $4K speakers into a $4k static producing machine.

So in order to help all the Bobs in the world I think this would be a great and easy feature to work in.

Print this item